News & Update

เมษานี้ Apple จะบังคับนักพัฒนาให้ทำแอพจาก Xcode 13 เท่านั้น

Apple เตือนนักพัฒนาอีกครั้งว่าตั้งแต่ 25 เมษายนนี้เป็นต้นไป แอพที่ส่งเข้ามายัง App Store จะต้องคอมไพล์จาก Xcode 13 เท่านั้น

Xcode 13

Xcode 13 เป็น SDK ตัวล่าสุดสำหรับนักพัฒนาที่ต้องการทำแอพสำหรับแพลตฟอร์ม Apple ไม่ว่าจะเป็น iOS / iPadOS / watchOS / macOS การบังคับให้ใช้คอมไพเลอร์รุ่นล่าสุดจะการันตีว่าแอพจะทำงานได้บนระบบปฏิบัติการรุ่นล่าสุดอย่างไม่มีปัญหา (iOS / iPadOS 15, watchOS 8, macOS 12)

แน่นอนว่า Xcode 13 เป็นรุ่นล่าสุด ฟีเจอร์ลูกเล่นสำหรับนักพัฒนาก็เพิ่มมากขึ้นไปด้วย โดยเฉพาะ API ใหม่ๆ ในระบบปฏิบัติการรุ่นล่าสุด เช่น SwiftUI, ARKit 5, Safari Extension for iOS, ShazamKit และ SharePlay

แม้ว่าแอพจะถูกคอมไพล์โดยรุ่นล่าสุดอย่าง Xcode 13 แต่ก็ไม่ได้แปลว่านักพัฒนาจะไม่สามารถทำแอพสำหรับระบบปฏิบัติการเก่า อย่างเช่น iOS 14 หรือ macOS 11 Big Sur ได้ แต่ตรงกันข้ามเพราะเวอร์ชันใหม่นี้รองรับการทำงานร่วมกับเวอร์ชันเก่าได้ดีเท่าที่เป็นมา ความเปลี่ยนแปลงหลักๆ คือจะมี API ใหม่ๆ ในระบบปฏิบัติการรุ่นล่าสุดให้ใช้ (รวมไปถึงถอดฟีเจอร์ที่หมดอายุใช้งานไปแล้ว) เท่านั้น

ที่มา – 9to5Mac

ร่วมแสดงความคิดเห็น

ความเห็น

To Top